010-63495805
您的当前位置:首页 > 行业知识 > 云服务器知识 >

阿里云服务器Windows 2008 IIS同时配置多版本的php

时间:2016-04-21

Windows可以通过IIS下安装PHP Manager工具让IIS可以同时支持多版本的php,具体步骤如下:
 
1.下载PHP Manager软件(可以在http://phpmanager.codeplex.com/releases/view/69115下载),下载后在服务器内双击安装文件进行安装,安装后打开IIS在站点右侧就会多出一个PHP Manager管理选项。

2.在系统盘C盘内创建个php文件夹,将不同版本的php文件都转移到此文件夹下,本教程使用的php5.2和php5.3版本的php。
 
 
3.进入IIS管理界面,双击PHP Manager,选择Register New PHP Version,在弹出的选择框中选择5.2版本目录下的php-cgi.exe文件,确认后,再此点击Register New PHP Version,选择5.3版本目录下的php-cgi.exe文件,同样确认后,多版本的环境就搭建好了。
 
 
 
 
4.需要用到哪个PHP版本时,就点击change PHP version选择需要的版本即可。可以点旁边的check phpinfo()来查看相应PHP版本和设置信息。
 

北京爱牛科技有限公司©版权所有 京ICP备10200143号-3